Just a HookHDU1698

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Problem Description

In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.
48569
Now Pudge wants to do some operations on the hook.
Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.

Input

The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.

Output

For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.

Sample Input

1
10
2
1 5 2
5 9 3

Sample Output

Case 1: The total value of the hook is 24.


输入一个n,表示n个钩子,每个钩子初值为1,
只有一个q,然后q个操作,a b c 表示从第a个到第b个改为c。
求最后所有钩子的总值


线段树区间更新求和
因为新增的更改会覆盖以前的,所以再更新的时候:
1,走到某个节点但不是目标区间且此节点有修改值。
2,将这个节点原有的值分到左右儿子位置,并将此节点归零。
3,继续往下递归

查询:
把所有的更改值传下来,计算。

只会有一层flag有修改值,其余都是0,因为在update 的时候遇到一个flag不为零则将这个flag压下去到儿子那里。


1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
#include<stdio.h>
int tree[400000];
int n, q, ans;
void build(int t, int l, int r)
{
tree[t] = 0;
if (l == r)
{
tree[t] = 1;
return;
}
int mid = l + r >> 1;
build(t << 1, l, mid);
build(t << 1 | 1, mid + 1, r);
}
void update(int t, int l, int r, int x, int y, int z)
{
if (l >= x&&r <= y)
{
tree[t] = z;
return;
}
if (tree[t] != 0)//这个点flag不为零,压下去
{
tree[t << 1] = tree[t << 1 | 1] = tree[t];
tree[t] = 0;
}
int mid = l + r >> 1;
if (x > mid)
{
update(t << 1 | 1, mid + 1, r, x, y, z);
}
else if (y <= mid)
{
update(t << 1, l, mid, x, y, z);
}
else
{
update(t << 1, l, mid, x, y, z);
update(t << 1 | 1, mid + 1, r, x, y, z);
}
}
void getans(int t, int l, int r)
{
if (tree[t] != 0)
{
ans += (r-l + 1)*tree[t];
return;
}
int mid = l + r >> 1;
getans(t << 1, l, mid);
getans(t << 1 | 1, mid + 1, r);
}
int main()
{
int T;
scanf("%d", &T);
for (int I = 1; I <= T; I++)
{
scanf("%d", &n);
build(1, 1, n);
scanf("%d", &q);
int l, r, t;
while (q--)
{
scanf("%d%d%d", &l, &r, &t);
update(1, 1, n, l, r, t);
}
ans = 0;
getans(1, 1, n);
printf("Case %d: The total value of the hook is %d.\n", I, ans);
}
}